Heads up!

Hi guys, we see a lot of people struggling with the recent TIME ZONE CHANGE in the United States, and with the upcoming time zone change in Europe (March 26th). If you see incorrect times in the appointments booked after Daylight Savings Time starts, the time zone of your WordPress site needs to be adjusted.

Please check out THIS ARTICLE about the time zones in Amelia.

  Public Ticket #3214426
Failure to create table


  • Zachary Kann started the conversation

    I'm trying to create a table from a Google spreadsheet. I published and shared the spreadsheet as indicated in the docs. However, when I hit "save changes" to create the table, I get a popup with this error message:

    Unknown column 'file_location' in 'field list'


    And the table does not get created. What do I do?

  •  1,362
    Miloš replied

    Hi, Zachary 

    Thanks for reaching out ot us.

    Basically, what happened is, during an update, we've included new features , 

    which was also added to the database as new columns in the 'wp_wpdatatables' table. 

     ( wp_ prefix is the default WordPress table prefix,

      but on your database, the table prefix might be different) 

    For some reason, the plugin couldn't create these columns, which resulted in the error - the plugin tried pulling the data,   while the columns were never created. 

    To prevent this from happening again in the future, you can reach out to your hosting provider and have them check if the plugins have the necessary permissions to create/update database tables.

    And you can run this SQL Query on your database ( via PhPMyAdmin for example),

    ALTER TABLE `wp_wpdatatables` ROW_FORMAT=DYNAMIC;

    As mentioned before, the wp_  table prefix might be different in your WordPress database, and if so, the Query would be

    ALTER TABLE `yourDBprefix_wpdatatables` ROW_FORMAT=DYNAMIC;

    We can do that for you, if you are not familiar with using PhPMyAdmin.


    There are two ways we can fix this issue for you right now.

    1. The easy way first :

    Please deactivate wpDataTables plugin,

    purge cache on your site;

    reactivate the plugin;

    purge cache again,

    and see if the issue goes away, let me know.


    If the issue persists, i can easily add this column in your database, if you could grant me access to your WP-Admin and the database.


    Please provide me a temporary WP-admin (administrator) user for your site where this happens, 

    and database access ( URL with credentials for PHPMyAdmin or cPanel access),

    so we could log in and take a look ‘from the inside’ as that’s the most efficient way to see and resolve the issue. 

    We do not interfere with any data or anything else except for the plugin (in case that’s a production version of the site), and of course, we do not provide login data to third parties. 

    You can write credentials here just check PRIVATE Reply so nobody can see them except us.

    Kind Regards, 

    Miloš Jovanović
    [email protected]

    Rate my support

    wpDataTables: FAQ | Facebook | Twitter | InstagramFront-end and back-end demo | Docs

    Amelia: FAQ | Facebook | Twitter | InstagramAmelia demo sites | Docs | Discord Community

    You can try wpDataTables add-ons before purchasing on these sandbox sites:

    Powerful Filters | Gravity Forms Integration for wpDataTables | Formidable Forms Integration for wpDataTables | Master-Detail Tables

  • Zachary Kann replied

    Running the alter table command you suggested, combined with the deactivate/purge/reactive/purge process, seems to have solved the problem. Thanks!

  •   Miloš replied privately