Okay
  Public Ticket #1543289
Search And Filters Not Typeale
Closed

Comments

  • mgenius11 started the conversation

    I have a SQL server side processing table set up.  Its loading fine but the search field isn't showing up nor are the filters.  The filters titles did show up initially but it was not possible to type into them.  Looks like the pagination is also not working.  I am only getting JS errors on the page with this shortcode added.  I've provided the URL.  

    Here is the error

    common.js?ver=4.9.5:34 Uncaught TypeError: $(...).popover is not a function
        at HTMLDocument.<anonymous> (common.js?ver=4.9.5:34)
        at i (jquery.js?ver=1.12.4:2)
        at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
        at Function.ready (jquery.js?ver=1.12.4:2)
        at HTMLDocument.K (jquery.js?ver=1.12.4:2)
    (anonymous) @ common.js?ver=4.9.5:34
    i @ jquery.js?ver=1.12.4:2
    fireWith @ jquery.js?ver=1.12.4:2
    ready @ jquery.js?ver=1.12.4:2
    K @ jquery.js?ver=1.12.4:2
    common.js?ver=4.9.5:234 Uncaught TypeError: jQuery(...).animateFadeOut is not a function
        at common.js?ver=4.9.5:234
        at dispatch (jquery.js?ver=1.12.4:3)
        at r.handle (jquery.js?ver=1.12.4:3)

    I've tried all combinations of settings and nothing seems to work unfortunately.  Can you please help me get this working?  It seems to work fine on the backend in the preview but not on the front end.

    I've tried deactivating and reactivating.  And after that the filters seemed to not work on the backend preview as well but the search still works.  I really just need that to work.

    Let me know if you need more info to help.

    Thanks in advance.

  •  211
    Milan replied

    HI mgenius11,
    Thank you for your purchase.

    There is some conflict with theme bootstrap framework. Can you please check is it turn on option Include bootstrap in main settings of plugin?

    If the answer is yes ,you can try to include our bootstrap on the page changing some code in file: 

    wp-content/plugins/wpdatatables/source/class.wdttools.php around line 799

    if (!$bootstrapEnqueued) {    
    wp_enqueue_script('wdt-bootstrap', WDT_JS_PATH . 'bootstrap/bootstrap.min.js', array('jquery'), false, true);
    }

    and remove if statment so the code look like this:

    wp_enqueue_script('wdt-bootstrap', WDT_JS_PATH . 'bootstrap/bootstrap.min.js', array('jquery'), false, true);

    You can try this but we can't promise that will not be some conflicts with theme bootstrap.

  • mgenius11 replied

    That worked.  Thank you!!!!

  •  211
    Milan replied

    HI mgenius11,

    You are welcome.  

    If you have any more issues or questions feel free to open a new ticket, we will gladly help.

    We'd greatly appreciate it if you could take a minute and leave a review on CodeCanyon on this link. Thanks!